Crashing every time I join

General Discussion Area
Posts: 2
Joined: Mon Aug 10, 2015 8:40 pm

Crashing every time I join

Postby TheDerpyNarwhal » Mon Aug 10, 2015 8:42 pm

I load into the server for about 1 second every time I connect and then the game crashes. If I join any other servers/single player, my game is stable. Any ideas on how to fix this? (Already tried reinstalling MC) :(

User avatar
Posts: 212
Joined: Wed Apr 24, 2013 8:44 pm

Re: Crashing every time I join

Postby Brecert » Tue Aug 11, 2015 1:08 am

It depends. I have never heard of it as Server Specific, but here are some suggestions (I dont have enough info on the problem).
1. If you have a recorce pack check that, you may have some type of custom language that is conflicting with the code. This is extreamly rare and should not happen withought poor coding/recorce pack dev. (Sorry Frost/Rec Pack Dev's)
2. It may be a mod conflicting with the code. Again rare but it is more common.
3. It may be that you have a corrupted save. Or that you are loading into a corrupted chunk, this would send invalid data to the client and crash it. (A Crash log would be nice...)
4. It may be the rendering system you use. You may be running out of memory. (Frostcraft is poorly optimised for laptops. I have learned this firsthand. Getting about 20 fps on the server and then 40-60 on mine)
5. Uhhh. Frost just is a bad coder? nah.
6. I have no idea. Make sure your joining on the right version. Some other servers support multiple versions by using plugins such as Carbon (and Co.)
7. Errr Hm. Uh. If none of those work. Uh. I guess. Hm. I need crash log and stuff I guess. Can't really help until then.

- Brecert

P.S : I'm banned I dont know if this is against the rules or not. But could you plea for me in vain? I miss FrostCraft so bad...

Posts: 2
Joined: Mon Aug 10, 2015 8:40 pm

Re: Crashing every time I join

Postby TheDerpyNarwhal » Tue Aug 11, 2015 1:19 am

Okay, I have no resource packs/mods/custom fonts installed on this machine, though I am too using a laptop, but my fps is just as it would be anywhere else: a constant 60. I highly doubt it is anything with code because from what I've seen, everything on the server works fluidly. But I personally think it may be a problem with the chunk I am in.

From what I'm understanding from the crash log, it's crashing upon attempting to tessellate a specific texture (Lines 29-33)

Crash log: http://pastebin.com/nSn34mQG

P.S. If this issue is fixed, I'll remember to ask for you, Brecert (Unless you are a dirty hacker and/or trollolol) c;

*Edit*

Lowered render distance to 2 chunks and typed in /spawn as fast as I could and boom no crash. Seems that it is similar to this error: https://bugs.mojang.com/browse/MC-81738

User avatar
Posts: 212
Joined: Wed Apr 24, 2013 8:44 pm

Re: Crashing every time I join

Postby Brecert » Sun Aug 16, 2015 8:01 pm

Well thats good you found a fix :3.

(and I am not a dirty hacker / spammer lolololol)
(though I am a Brecert(tm) and I do Brecert(tm) things. (its a joke from FrostMiser. It stuck to me since)
☺ME☻
╔══════════════════════════════════╗
╠ YOU WOULDNT PUNCH A SHEEP WOULD YOU? ╣
╚══════════════════════════════════╝

Image

Posts: 16
Joined: Tue Dec 30, 2014 4:53 am

Re: Crashing every time I join

Postby SkyAngel29 » Thu Sep 24, 2015 10:23 pm

Some times if you are in a higher vision than 1.8.1 and you are near dragon lands you crash

Return to General Discussion

Who is online

Users browsing this forum: Bing [Bot] and 9 guests